해외 웹호스팅 FastComet: PHP 8.0 지원

2021. 6. 12. 05:24 | 댓글 1

PHP 8.0을 지원하는 웹호스팅이 늘어나고 있습니다. 최근 해외 웹호스팅 FastComet에서도 PHP 8.0에 대한 지원을 추가했습니다. 이 글에서는 FastComet에서 PHP 8.0을 적용하는 방법에 대해 살펴보겠습니다.

이 글을 작성할 당시 블루호스트의 경우 공유호스팅은 7.4까지 적용이 가능했지만 2021년 7월에 PHP 8.0 지원이 추가되었습니다("블루호스트 PHP 8.0 적용하기(Bluehost 공유호스팅 & VPS)"). 저는 PHP 8.0을 적용해보니 구글 페이지스피드 인사이트 점수가 거의 98~100점이 나왔습니다.

 

워드프레스 GeneratePress 테마: 구글 페이지 스피드 인사이트 점수

GeneratePress 테마가 설치된 워드프레스 사이트에 PHP 8.0을 적용한 후에 구글 페이지 스피드 인사이트 툴을 사용하여 점수를 확인해보니 모바일과 PC 모두 점수가 향상되었습니다. 블루호스트 등의

avada.tistory.com

해외 웹호스팅 FastComet에서 PHP 8.0 적용하기

FastComet에서는 PHP 7.4까지 제공되었지만 최근 PHP 8.0 지원이 추가되었습니다. 인기 워드프레스 테마와 플러그인에서는 PHP 8.0을 지원할 가능성이 높지만, 일부 테마와 플러그인은 PHP 8.0을 지원하지 않을 수도 있습니다.

패스트코멧(FastComet)에서 PHP 8.0을 적용하려면 먼저 cPanel에 접속하도록 합니다.

FastComet cPanel 접속

cPanel에 접속하면 php로 검색하고 Select PHP Version (PHP 버전 선택) 툴을 클릭합니다.

해외 웹호스팅 FastComet: PHP 8.0 지원

PHP 버전 선택 화면이 표시됩니다. Extensions (익스텐션) 탭에서 Current PHP version (현재 PHP 버전) 옆의 드롭다운 메뉴를 클릭하여 8.0을 선택합니다.

그런 다음 8.0 옆의 Set as current (현재 PHP 버전으로 설정)를 클릭합니다.

이제 PHP 8.0이 적용되었습니다. 다음으로 할 일은 PHP 환경 설정값을 높여주는 것입니다. Options (옵션) 탭을 선택합니다.

max_execution_time, max_input_time, max_input_vars, memory_limit, post_max_size, upload_max_filesize 등의 설정값을 적절히 높여주도록 합니다.

참고로 엘리멘터 페이지 빌더로 페이지 편집 시 '미리보기를 표시할 수 없습니다' (Preview Could Not Be Loaded) 오류가 발생하는 경우 max_input_vars 값을 5000으로 높여보시기 바랍니다. 저는 3000으로 설정했을 때 이 오류가 자주 발생하여 5000으로 높였습니다.

PHP 8.0 버전 적용 후 오류가 발생하는 경우

PHP 8.0 버전을 설정하면 일부 워드프레스 사이트에서 오류가 발생할 수 있습니다. 저는 일부 사이트에서 다음과 같이 "Error establishing a database connection" 오류가 발생했습니다.

이 경우 1) 먼저 PHP 버전을 7.4나 이전 버전으로 낮추어 봅니다. 그래도 해결되지 않으면 2) 라이브 채팅으로 FastComet 고객센터에 연락하면 지난 7일 이내의 백업본으로 복원시켜줍니다.

 

해외 웹호스팅 FastComet 백업 서비스 (복원)

해외 웹호스팅 중 하나인 FastComet에서는 사이트에 문제가 발생 시 백업본을 사용하여 롤백할 수 있는 기능을 기본적으로 제공합니다. FastComet(패스트코멧)에서 호스팅 중인 사이트에 문제가 발생

avada.tistory.com

만약 8.0을 적용했을 때 문제가 발생하여 사이트를 복원한 경우, 다시 PHP 8.0을 적용하면 동일한 오류가 발생할 수 있으므로 사용 중인 워드프레스 테마나 플러그인이 PHP 8.0 버전과의 호환성 문제가 해결될 때까지 기다렸다가 PHP 8.0으로 적용해볼 수 있습니다.

오랫동안 업데이트가 안 되는 플러그인이나 테마는 PHP 8.0에서 문제가 발생할 가능성이 높을 것입니다. PHP 8.0이 적용된 제 Bluehost VPS 계정에는 GeneratePress, Newspaper, Divi 테마 등이 설치된 워드프레스 사이트들이 있는데, 모두 문제가 발생하지 않았습니다. 인기 테마와 플러그인은 자주 업데이트가 되므로 PHP 8.0 버전에서 문제가 발생할 가능성이 낮은 것 같습니다.

가성비가 좋은 웹호스팅을 원하는 경우 블루호스트 웹호스팅 서비스를 고려해볼 수 있습니다. 여기에서 블루호스트에 대한 자세한 정보를 확인해볼 수 있습니다. (참조된 글에 포함된 링크를 클릭하여 블루호스트 서비스에 가입하면 월 1달러 할인된 월 최저 2.95달러부터 서비스 이용이 가능합니다.) 저렴하게 비교적 괜찮은 호스팅을 원하는 경우 하나의 선택지가 될 수 있습니다.

참고

https://avada.tistory.com/2244

 

해외 호스팅 GreenGeeks: PHP 8 적용 시 워드프레스 오류가 발생하는 경우

해외 웹호스팅 중 하나인 GreenGeeks는 지난 5월 1일에 모든 서버를 LiteSpeed Web Server 6로 업그레이드하고 PHP 8.0도 지원되어 비교적 빠른 성능을 보여주는 것 같습니다. 하지만 그린긱스에서 PHP 버전 8

avada.tistory.com

https://avada.tistory.com/2155

 

빠른 워드프레스 블로그용 테마 - GeneratePress

워드프레스에는 정말로 많은 무료 및 유료 테마가 있기 때문에 사용 목적에 따라, 개인 취향에 따라 마음에 드는 것을 선택하여 사용할 수 있습니다. 블로그를 운영하는 경우 GeneratePress와 같은

avada.tistory.com

 

 

Bluehost 대안: FastComet, GreenGeeks, SiteGround - 웹사이트

저는 오랫동안 Bluehost(블루호스트)와 SiteGround(사이트그라운드)를 사용해왔습니다. 블루호스트는 우리나라에도 잘 알려진 해외 호스팅 중 하나입니다. 저는 나름 만족하고 사용하고 있지만(이 블

iwordpower.com

 

  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

">
  1. thumbnail
    空空(공공)

    해외 웹호스팅의 PHP 8.0 지원하는 내용이로군요
    기분 좋은 주말 보내시기 바랍니다^^