NET::ERR_CERT_DATE_INVALID 오류가 발생하는 경우 (SSL 인증서 문제)

2018. 8. 19. 10:55 | 댓글 0

NET::ERR_CERT_DATE_INVALID 인증서 오류

간혹 위의 그림과 같이 어떤 사이트를 방문했을 때 NET::ERR_CERT_DATE_INVALID 오류가 발생하는 경우가 있습니다.

연결이 비공개로 설정되어 있지 않습니다.
해커가 example.com에서 정보(예: 비밀번호, 메시지, 신용카드 등)를 도용하려고 시도 중일 수 있습니다. 자세히 알아보기
NET::ERR_CERT_DATE_INVALID

목차

    NET::ERR_CERT_DATE_INVALID 오류가 발생하는 경우 대처 방법 (보안서버 SSL 인증서 문제)

    이 오류는 보통 SSL 인증서가 설치되지 않은 사이트를 https://... 프로토콜을 입력하여 방문하는 경우에 발생합니다. 혹은 SSL 인증서가 만료된 후에 제대로 갱신되지 않았을 수도 있습니다. "자세히 알아보기"를 클릭하면 자세한 정보를 확인해볼 수 있습니다.

    NET::ERR_CERT_DATE_INVALID 인증서 오류

    이 경우 Let's Encrypt 보안서버 인증서가 8월 18일에 만료되었지만 갱신되지 않아서 인증서 오류가 발생하고 있습니다.

    Let's Encrypt는 3개월마다 갱신을 해주어야 하고 만료 1개월 전부터  갱신할 수 있습니다. 혹은 자동으로 갱신되도록 설정하는 것도 가능합니다.

    관리하는 사이트에 NET::ERR_CERT_DATE_INVALID 오류가 발생하는 경우 다음 조치를 취할 수 있습니다.

    • SSL 인증서 설치
    • SSL 인증서가 만료된 경우 갱신하기

    직접 서버를 구성한 경우 무료 Let's Encrypt SSL 인증서를 설치하거나 갱신해주면 됩니다.

    (제가 자주 방문하는 사이트 두 군데서 NET::ERR_CERT_DATE_INVALID 오류 메시지가 표시되고 있네요. 사이트 운영자가 바쁘거나 여름 휴가를 가서 SSL 인증서를 갱신하지 않고 있는 것 같습니다.)

    카페24 등 국내 호스팅에서는 SSL 인증서를 유료로 판매하고 있습니다. SiteGround, Bluehost, A2 Hosting 등 해외 호스팅에서는 무료로 SSL 인증서를 제공합니다.

    블루호스트나 사이트그라운드에서 무료 SSL 인증서를 설치하면 3개월마다 인증서가 자동 갱신됩니다. 하지만 오류로 인해 간혹 자동 갱신이 안 되는 경우가 있을 수 있습니다. 자동으로 갱신이 안 되고 NET::ERR_CERT_DATE_INVALID 오류가 발생하면 라이브 채팅을 통해 연락하면 수동으로 갱신해줍니다.

    최근 크롬이 68 버전으로 업데이트되면서 HTTP로 로드되는 모든 사이트에 대하여 크롬 브라우저에서 ‘주의 요함‘ 경고 문구를 표시하고 있습니다. 중요한 사이트라면 SSL 인증서를 설치하는 것이 SEO에 유리합니다.

    참고



    • 네이버 블러그 공유하기
    • 네이버 밴드에 공유하기
    • 페이스북 공유하기
    • 트위터 공유하기
    • 카카오스토리 공유하기

    댓글을 달아 주세요

    ">