FTP 접속 시 '550 PWD: Permission denied' 오류가 발생하는 경우

2020. 5. 20. 01:47 | 댓글 2

파일질라 등 FTP 클라이언트 프로그램을 사용하여 FTP에 접속할 때 '550 PWD: Permission denied' 오류가 발생하면서 FTP 서버에 접속하지 못하는 경우가 있습니다. 이 문제는 매우 드물게 발생하는 것 같습니다. 이 오류는 서버와 관련된 문제입니다.

FTP 접속 시 '550 PWD: Permission denied' 오류가 발생하는 경우 대처 방법

지난주에 카페24에 호스팅 중인 워드프레스 사이트가 빈 화면으로 표시되면서 접속되지 않는 문제를 맡게 되었습니다. 문제의 원인을 파악하기 위해 FTP 서버에 접속하려고 시도했지만 다음과 같은 오류가 발생하면서 FTP 자체에 접속이 불가능했습니다.

"응답: 550 PWD: Permission denied" 메시지와 함께 "오류: 디렉터리 목록을 조회하는 데 실패함"이라는 에러가 표시되었는데요. 혹시 비밀번호가 잘못되었는가 싶어 다른 비밀번호(잘못된 비밀번호)를 입력하니 "응답: 530 Login incorrect. 오류: 치명적 오류: 서버에 연결하지 못함" 오류 메시지가 표시되었습니다.

즉, 올바른 비밀번호를 입력하면 550 PWD: Permission denied 에러가 발생하고 잘못된 비밀번호를 입력하면 530: Login incorrect 에러가 발생했습니다.

'550 PWD: Permission denied' 오류는 서버 문제

'550 PWD: Permission denied'는 퍼미션 즉 권한이 부족하다는 의미로 서버에서 PWD command를 막고 있기 때문에 발생한다고 합니다. 

이 문제와 관련하여 FileZilla Forum(forum.filezilla-project.org/viewtopic.php?t=12638) 글에서는 다음과 같이 설명합니다.

Yes, contact the server people, they are blocking the PWD command. FileZilla requires it to work.

FileZilla가 작동하려면 PWD command가 필요하지만 서버에서 차단하고 있기 때문에 이 문제가 발생하므로 이 오류가 발생하면 웹호스팅 업체에 연락하여 문제를 해결해야 합니다.

경과

고객을 통해 카페24에 연락하니 사이트에 "Parse error: syntax error, unexpected '[' ..." 오류가 발한다고 알려주었습니다. 하지만 FTP 액세스 문제는 여전히 해결되지 않아 다시 고객에게 카페24에 연락하여 FTP 접속 문제를 해결하라고 알려주었습니다.

워드프레스 문제는 PHP 버전이 PHP 5.3으로 버전이 너무 낮아서 발생하는 문제였습니다. PHP 버전을 상향 조정하니 문제는 해결되었습니다. 하지만 PHP 버전이 너무 낮다는 것은 오래전에 사이트를 만들었다는 것을 의미합니다. 그 사이 제대로 업데이트를 하지 않았다면 보안상, 기능상 사이트에 문제가 발생할 가능성이 있습니다.

 

PHP Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or '$' ... 오류 - 낙서장

워드프레스 테마나 플러그인을 설치할 때 간혹 'PHP Parse error: syntax error, unexpected' 오류가 발생하는 경우가 있습니다.

www.thewordcracker.com

워드프레스 자체는 보안에 강하지만 워드프레스, 테마, 플러그인을 제 때 업데이트하지 않으면 보안 문제가 발생할 수 있습니다. 가능한 경우 최신 버전으로 업데이트하고 정기적으로 백업하면 워드프레스 사이트를 안전하게 운영할 수 있습니다.

워드프레스에서는 PHP 7.3 이상을 권장하고 있습니다. 현재 PHP 7.0이면 무난하게 워드프레스를 운영할 수 있지만 가급적 PHP 7.3 이상을 적용하는 것이 좋을 수 있습니다.

PHP 7.4에서도 워드프레스가 잘 작동하지만 일부 테마나 플러그인이 제대로 작동하지 않을 수는 있습니다. 저는 가능한 경우 모두 PHP 7.4를 적용하여 사용하고 있습니다. 서버를 직접 세팅하여 운영하는 경우 PHP 7.4를 설치하거나 업그레이드할 수 있습니다. 사이트그라운드, Bluehost VPS 등에서도 PHP 7.4를 지원합니다.

 

블루호스트 VPS에서 PHP 7.4 적용 방법 - 기타

현재 블루호스트 공유호스팅에서는 PHP 7.3까지 지원되지만 블루호스트 VPS에서는 PHP 7.4 버전까지 적용이 가능합니다. 블루호스트 VPS를 이용하는 경우 WHM에 접속하여 PHP 7.4를 추가하여 사이트에 P

www.thewordcracker.com

참고:

 

FTP 파일 업로드 실패 시 확인 사항

FTP에 파일을 업로드하는 과정에서 실패하는 경우가 있습니다. 특히 파일 개수가 많거나 전체 용량이 큰 경우에 문제가 많이 발생합니다. FTP 파일 업로드 과정에서 실패하는 경우 다음 사항을 확

avada.tistory.com

 

  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

">
  1. thumbnail
    공수래공수거

    이런 오류도 생기는군요.
    전 처음 보는 오류같습니다.