본문 바로가기

워드프레스 더세븐(The7) 테마 업데이트 시 참고사항

2019.07.31 댓글 2

어제는 오랫동안 업데이트하지 않은 워드프레스 사이트를 최신 워드프레스 버전과 테마 버전으로 업데이트하는 작업을 맡았습니다. 이 작업에 앞서 먼저 PHP 버전을 5.3에서 7.0으로 업그레이드를 했습니다.

2015년에 더세븐(The7) 테마로 구축한 사이트였는데, 사이트가 만들어진 이후로 테마와 플러그인의 업데이트를 하지 않은 상태였습니다.

이렇게 오랫동안 사이트를 업데이트하지 않다가 최신 버전으로 업데이트하면 사이트가 깨질 가능성이 높습니다. 그러므로 업데이트 작업을 시작하기 전에 데이터와 DB를 철저히 백업하는 것이 안전합니다.

참고로 테마를 설치하고 인증을 하지 않은 상태로 오랫동안 운영하다가 테마 라이선스를 구입하여 Item Purchase Code를 입력하면 'The old Envato API is deprecated' 또는 'Rate limiting on the legacy API....' 비슷한 오류가 발생하면서 테마 인증에 실패할 수 있습니다.

이런 오류가 발생하면 FTP를 통해 테마 설치 파일을 업로드하는 방식으로 업데이트한 후에 테마 인증을 시도해야 합니다.

The7의 경우 오랜 만에 테마를 업데이트하면 사이트가 제대로 표시되지 않을 수 있습니다. 어제 작업에서는 전면 페이지가 검은색 배경이 되면서 이상하게 표시되었습니다.

관리자 페이지에 접속했을 때 "Would you like to import The7.2 settings?" 상자가 표시되면 "Yes, do it!"을 클릭하여 The7.2 설정을 임포트하도록 합니다.

그러면 사이트가 완전히 이상하게 보이는 문제는 해결될 것입니다. 그러나 헤더 부분과 푸터 부분을 비롯하여 사이트가 전반적으로 이전 레이아웃과 조금씩 다르게 보일 수 있습니다. 그런 경우 하나씩 체크하여 세팅을 해주거나 CSS 등으로 스타일을 조정해 주어야 할 수 있습니다.

이상하게 포트폴리오(Portfolio)로 된 부분이 dt_portfolio가 포함된 쇼트코드로 표시되었습니다. 이 경우 “The7 Elements”라는 플러그인을 설치해주면 문제가 해결될 것입니다.

더세븐은 Top 10 테마 리스트에 이름을 올리다가 2~3년 전에 10위 밖으로 밀려난 후에 테마 가격을 39달러로 낮추면서 베스트셀링 테마 리스트에 다시 진입했습니다.

더세븐은 현재 테마포레스트 마켓에서 주간 판매 3위를 기록하고 있습니다. 판매 1위는 아바다 테마로서 6년 연속 1위 자리를 지키면서 50만 개 이상 판매되었습니다.


워드프레스, 테마, 플러그인의 업데이트가 나올 때마다 해주면 오류가 발생하더라도 쉽게 대응이 가능하지만, 오랫동안 업데이트를 않다가 한꺼번에 업데이트하면 문제가 발생할 가능성이 높습니다.

보안을 위해서도 가능하면 항상 최신 버전으로 사이트를 업데이트하는 것이 바람직합니다.

참고:

※일부 글에 제휴 링크가 포함될 수 있습니다.

댓글2