Warning: array_merge(): Expected parameter 2... 경고 메시지가 표시되는 경우

2019. 5. 7. 17:19 | 댓글 3

워드프레스 베스트셀링 테마인 아바다(Avada)가 설치된 사이트에 다음과 같은 오류 메시지가 표시되었습니다.

Warning: array_merge(): Expected parameter 2 to be an array, null given in /home/xxxxx/public_html/wp-includes/load.php on line 66

그리고 사이트그라운드(SiteGround)의 최적화 플러그인인 SG Optimizer를 활성화하면 다음과 같은 경고도 표시되었습니다.

Warning: Cannot modify header information - headers already sent by (output started at /home/xxxxx/public_html/wp-includes/load.php:66) in /home/xxxxx/public_html/wp-content/plugins/sg-cachepress/core/Supercacher/Supercacher_Helper.php on line 41

이와 같은 오류는 여러 원인에 의해 발생할 수 있겠지만, 먼저 PHP 버전을 의심해볼 수 있습니다. PHP 버전이 너무 높은 경우에 이와 같은 경고 메시지가 표시될 수 있습니다.

저는 PHP 버전을 7.3에서 7.2(또는 7.1)로 다운그레이드하니 경고 메시지가 사라졌습니다.

사이트그라운드 PHP 버전 변경

사이트그라운드에서는 최상위 폴더와 첫 번째 레벨의 하위 폴더에 기본 PHP 버전과 다른 버전을 지정할 수 있습니다. 현재 PHP 7.3.4까지 지원되고 있네요.

참고로 5월 7일(우리나라 시각으로 5월 8일 오전경)에 워드프레스 5.2 버전 릴리즈가 예정되어 있습니다. 워드프레스 5.2에서는 블록 에디터(구텐베르크)의 성능이 개선되고, 특히 최소 PHP 요구사항이 PHP 5.6 버전으로 변경됩니다.

가급적 PHP 7 버전으로 업그레이드하는 것이 보안과 속도면에서 유리합니다.

PHP 버전이 낮은 경우 웹호스팅 업체에 문의하면 PHP 버전을 업그레이드하는 방법을 알려줄 것입니다.

PHP 버전이 높을 수록 보안과 성능면에서 우수하기 때문에 가능하면 높은 PHP 버전으로 업그레이드하는 것이 좋습니다.

하지만 사용 중인 테마나 플러그인 때문에 오류(예: Warning: array_merge(): Expected parameter 2...)가 발생하면 한 단계 낮은 PHP 버전으로 낮추면 에러가 해결될 수도 있습니다.

참고:

  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

">
  1. thumbnail
    IT세레스

    PHP 버전 업그레이드가 많이 되었군요.

  2. thumbnail
    공수래공수거

    Warning 메시지가 뜨면 괜히 긴장하게 됩니다.
    생각난 김에 컴 자료 백업좀 받아 놓아야 겠습니다.^^