워드프레스 로그인 문제 - ERR_EMPTY_RESPONSE 오류

2018. 6. 26. 07:59 | 댓글 0

워드프레스 문제해결

어제는 워드프레스 사이트로 로그인을 시도하면 다음과 같이 '페이지가 작동하지 않습니다. ...에서 전송한 데이터가 없습니다. ERR_EMPTY_RESPONSE' 오류 메시지가 표시되어 관리자 페이지에 접속하지 못하는 문제를 맡았습니다.

ERR_EMPTY_RESPONSE 오류 발생 시 확인 사항

이런 경우 보통 캐시 플러그인이 문제의 원인일 수 있습니다. 하지만 캐시 플러그인을 삭제해도 문제가 해결되지 않아서 조금 시간이 걸려서 문제를 겨우 해결할 수 있었습니다.

로그인이 되고, 글 편집까지 되는 것을 확인한 후에 클라이언트에 연락하여 문제 해결을 위해 캐시 플러그인(WP Super Cache)을 삭제했으니까 다시 설치하라고 알려주었습니다.

하지만 클라이언트가 캐시 플러그인을 설치하면 오류가 발생한다고 하여 사이트를 살펴보니 PHP 버전이 너무 오래되었고 PHP 환경 설정값이 너무 낮게 설정되어 있었습니다.

PHP 버전이 5.2로 너무 낮습니다. 현재 워드프레스 권장 PHP 사양은 7.2 이상입니다.

WP Super Cache 플러그인이 설치되지 않은 이유는 PHP 버전이 너무 낮고 워드프레스도 오랫동안 업데이트가 되지 않았기 때문에 제대로 설치되지 않았던 것 같습니다. 그리고 PHP 환경 설정값도 너무 낮아서 요즘 나오는 테마나 플러그인이 작동할 수 없는 상태였습니다.

클라이언트에게 사이트를 제작한 업체에 연락하여 비용을 좀 들여서 워드프레스, 테마, 플러그인을 모두 최신 버전으로 업데이트해달라고 요청하라고 알려주니, 제작업체에서는 클라이언트가 유지보수 서비스를 신청하지 않았기 때문에 자기네는 모른다고 한다네요.

워드프레스, 테마, 플러그인을 업데이트하지 않고 운영할 경우 멀웨어나 해킹에 노출될 가능성이 높습니다. 실제로 악성코드에 감염되어 치료와 복구를 의뢰하는 분들이 있습니다.

클라이언트에게 원할 경우 테스트 서버를 만들어서 사이트를 그대로 이전하여 업데이트 테스트를 진행하는 것을 고려해볼 것을 제안했습니다.

저는 보통 해외 호스팅 중 하나인 사이트그라운드에 테스트 사이트를 만들어 테스트를 진행합니다. 사이트그라운드는 최신 PHP 버전(현재 7.2)를 지원하고 폴더별로 쉽게 PHP 버전을 변경하여 테스트할 수 있는 장점이 있습니다. (카페24나 대부분의 호스팅 업체에서 PHP 버전을 바꾸는 작업이 그리 쉽지 않습니다.)

워드프레스 자체는 보안에 강하지만, 잘못된 보안 관행(예: 약한 비밀번호 사용, admin 등을 관리자 ID로 사용)이나 업데이트 소홀로 인해 해킹을 당하거나 멀웨어 등에 감염되어 피해를 볼 수 있습니다.

항상 최신 버전으로 유지하는 것이 보안상 중요합니다. 그리고 정기적인 백업도 잊지 마세요.

워드프레스와 관련된 문제로 인해 어려움을 겪거나 멀웨어 등 악성코드에 감염된 경우, 혹은 테스트 사이트를 만들어 업데이트를 테스트해보고 싶은 경우 여기에서 서비스(유료)를 의뢰하실 수 있습니다.

관리자 페이지에 로그인이 안 되는 경우 다음 글을 참고하여 문제 해결을 시도해볼 수 있습니다.

참고:


  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

">