워드프레스 사이트에서 'WordPress 5.6 requires at least 5.6.20' 오류 메시지가 표시되는 경우

2021. 1. 24. 15:54 | 댓글 2

워드프레스를 설치할 때 혹은 워드프레스가 설치된 사이트에 접속했을 때 다음과 같은 오류가 발생하면서 워드프레스를 설치할 수 없거나 사이트에 접속할 수 없는 경우가 있습니다.

Your server is running PHP version 5.5.17p1 but WordPress 5.6 requires at least 5.6.20.

이와 같은 오류가 발생하는 경우 대처 방법에 대해 살펴보겠습니다.

워드프레스 사이트에서 'WordPress 5.6 requires at least 5.6.20' 오류 메시지가 표시되는 경우

이 오류는 최신 워드프레스를 설치하려면 PHP 5.6.20 이상이 필요하지만 해당 서버의 버전이 이보다 낮을 때 발생합니다.

이 경우 두 가지 옵션이 있습니다.

  1. PHP 버전 업그레이드가 가능한 경우: PHP 버전을 업그레이드하면 문제가 해결됩니다.
  2. PHP 버전 업그레이드가 불가능한 경우: 이 경우에는 워드프레스 4.9.x 버전을 다운로드하여 설치할 수 있습니다.

바람직한 방법은 PHP 버전을 가능한 경우 PHP 7.3 또는 PHP 7.4로 업그레이드하는 것입니다. 현재 PHP 7.2 이하 버전은 지원이 종료되었기 때문에 보안상에도 바람직하지 않고, PHP 5.x의 경우 사이트 속도도 느릴 수 있으므로 가급적 PHP 7.3 이상으로 업그레이드하는 것을 고려해보시기 바랍니다.

블루호스트 (Bluehost)를 이용하는 경우 PHP 7.4까지, 카페24의 경우 현재 PHP 7.3까지 지원됩니다.

 

블루호스트에서 PHP 버전과 PHP 환경 설정값 변경하기 (새로운 cPanel 인터페이스)

이제 블루호스트 공유호스팅에서도 PHP 7.3까지 지원합니다. 새로 가입하는 경우 PHP 7.3이 기본 적용되어 있습니다. 새로운 인터페이스에서 PHP 버전과 환경값을 설정하는 방법을 설명합니다.

www.thewordcracker.com

카페24에서 PHP 버전을 변경하는 경우에는 반드시 백업을 받아놓으시기 바랍니다. 간혹 백업을 안 받았다가 사이트를 날리는 분들도 있습니다.

이용하는 웹호스팅 업체의 제약 때문에 PHP 버전을 업그레이드할 수 없는 경우에는 워드프레스 4.9 브랜치 버전을 설치하여 작동하는지 테스트해보시기 바랍니다.

현재 4.9 Branch 중 가장 최신 버전은 4.9.16입니다.

마치며

현재 워드프레스 권장 PHP 버전은 7.4 이상입니다. PHP 8.0이 릴리즈되었지만 아직은 지원되지 않는 테마나 플러그인이 많기 때문에 PHP 8.0이 자리 잡으려면 조금 시간이 걸릴 것 같습니다. 가능한 경우 PHP 7.3이나 7.4를 이용하시고, 최소한 PHP 7.0 이상을 적용해야 원활하게 워드프레스를 이용할 수 있을 것입니다.

참고

 

워드프레스 5.6 업데이트 - PHP 8 지원 및 Twenty Twenty-One 테마 추가 - 워드프레스 정보꾸러미

워드프레스 5.6이 12월 8일(우리나라 시각으로 12월 9일) 릴리스되었습니다. 5.6 버전은 메이저 업데이트로서 많은 변경 사항이 추가되었습니다. 이번 업데이트에서는 PHP 8에 대한 지원이 추가되었

www.thewordcracker.com

 

  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

">
  1. thumbnail
    Deborah

    접속 오류가 발생하면 당황이 되곤하는데요. 위에 올려 주신 방법으로 해결책을 주셨네요. 아주 유익한 내용입니다. 행복한 밤 되세요.

  2. thumbnail
    空空(공공)
    2021.01.25 06:13

    관리자의 승인을 기다리고 있는 댓글입니다