워드프레스에서 'Illegal string offset warning...' 오류가 발생하는 경우

2017. 12. 10. 14:43 | 댓글 0

워드프레스 플러그인을 하나 설치했더니 Warning: Illegal string offset... 오류가 발생하면서 제대로 작동하지 않네요.

이 문제를 조금 검색해보니 PHP 버전과 관련이 있는 것 같습니다. 다음 글을 참고해보세요.

PHP 버전을 7.1에서 7.0으로 변경을 하니까 문제가 해결되네요.ㅎㅎ 만약 7.0으로도 문제가 해결되지 많으면 PHP 5.6으로 하향 조정하면 문제가 해결될 것 같습니다.

해외 호스팅 중 하나인 Siteground는 서브 폴더의 PHP 버전을 달리 지정하는 것이 가능합니다. 그리고 PHP 버전도 7.0과 7.1은 물론 PHP 7.2도 적용할 수 있습니다.

문제가 PHP 버전 때문에 발생하는지 여부를 확인하려는 경우에 Siteground의 cPanel에서 제공되는 PHP Version Manager를 이용하여 쉽게 서브 폴더의 PHP 버전을 변경하여 확인해볼 수 있습니다.

참고:

  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

">