본문으로 바로가기
  1. Home
  2. 워드프레스
  3. 워드프레스 블록 에디터 비활성화 - 고전 편집기 설치

워드프레스 블록 에디터 비활성화 - 고전 편집기 설치

· 댓글 8

워드프레스에서 비주얼 컴포저 등의 페이지 빌더가 제대로 작동하지 않거나 워드프레스 업데이트 후 페이지 편집 시 문제가 발생하는 경우 블록 에디터와의 충돌을 의심해볼 수 있습니다. 그런 경우 고전 편집기를 설치하여 워드프레스 블록 에디터를 비활성화하면 문제가 해결될 수 있습니다.

목차

    워드프레스 블록 에디터 비활성화 - 고전 편집기 설치

    워드프레스가 버전 5로 업데이트되면서 새로운 편집기인 구텐베르크(블록 에디터)가 기본 편집기로 탑재되었습니다.

    일부 테마나 플러그인이 구텐베르크와 충돌을 일으켜 글 편집 시 이상하게 작동하는 경우가 있습니다. 예를 들어, 글이 업데이트가 안 되거나 발행이 안될 수 있습니다.

    그런 경우 고전 편집기 플러그인을 설치하면 문제가 해결될 수 있습니다.

    워드프레스 알림판 > 플러그인 > 새로 추가에서 classic editor를 검색하여 "고전 편집기"를 설치할 수 있습니다.

    워드프레스 고전 편집기

    고전 편집기(Classic Editor)는 2021년 12월 31일까지 공식 지원됩니다. 워드프레스가 버전 5로 업데이트된 직후에는 안정화가 되지 않아 다소 불안한 측면이 있었지만, 지금은 많이 안정화되었습니다.

    만약 고전 편집기를 설치하여 활성화하는 방법으로도 문제가 해결되지 않으면 다음 사항을 체크해보시기 바랍니다.

    • 방화벽 비활성화(해당되는 경우)
    • 브라우저를 변경하여 테스트 (예: IE를 사용하는 경우 크롬이나 파이어폭스에서 테스트)
    • 브라우저 캐시 삭제, 테마 캐시 삭제, 캐시 플러그인의 캐시 삭제 후 테스트
    • 플러그인을 모두 비활성화하여 문제가 해결되는지 확인하여 문제를 일으키는 플러그인을 비활성화
    • PHP 환경 설정값 체크
    • PHP 버전 체크

    PHP 버전은 7.0 이상을 선택하고, 가능하면 PHP 7.3이나 7.2 혹은 7.1을 선택하는 것이 좋습니다. PHP 버전이 높을 수록 속도와 보안면에서 유리합니다.

    PHP 버전이 7.3인 경우 7.2나 7.1로 다운그레이드한 후에 문제가 해결되는지도 체크해보시기 바랍니다. 일부 테마나 플러그인에서 PHP 7.3과 호환되지 않을 수도 있습니다. (테마와 플러그인, 그리고 워드프레스 버전을 최신 버전으로 업데이트해야 안전하게 사이트를 운영할 수 있습니다.)

    ※업데이트: 워드프레스 권장 PHP 버전이 7.3 이상으로 상향 조정되었습니다.

    참고:


    💬 댓글 8
    logo

    워드프레스에서 고전편집기를 사용하는 방법이군요. 실력이 좀 쌓이면 워드프레스로 블로그를 운영해보고 싶긴하네요.

    logo

    초보자도 시작할 수 있습니다.ㅎㅎ

    logo

    충돌이 나면 고전편집기를 설치해 활용해보는 것이 좋은 해결책이 될 수 있겠어요.

    logo

    페이지 편집 시 문제가 발생할 경우 기존 편집기를 설치하면 문제가 해결될 수도 있습니다. :)

    logo

    워드프레스 기존 편집기가 더 좋다는 평가가 있더라구요.

    logo

    새로운 편집기(구텐베르크)가 도입되는 과정에서 잡음이 많았고 초기에는 불안정했지만, 지금은 기능이 많이 개선되었습니다.

    logo

    위드프레스에서 고전편집기를 설치해 활용하는 방법이로군요^^

    logo

    감사합니다~

    즐거운 하루 보내시기 바랍니다 :)

    이름을 저장합니다.

    이모티콘창 닫기
    울음
    안녕
    감사해요
    당황
    피폐

    이모티콘을 클릭하면 댓글창에 입력됩니다.

    프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드