워드프레스에서 'Something went wrong with the plugin API' 오류가 발생하는 경우

2020. 7. 23. 03:52 | 댓글 0

워드프레스 (WordPress)에서 플러그인 설치 시에 'Something went wrong with the plugin API' 오류가 발생하는 경우가 있습니다. 이 문제는 매우 드문 상황에서 발생하는 것 같습니다. 이 문제가 발생하면 수동으로 플러그인 설치를 시도해볼 수 있습니다.

워드프레스에서 'Something went wrong with the plugin API' 오류가 발생하는 경우

이 오류는 테마에 포함된 특정 플러그이을 설치할 때 발생할 수 있습니다. 이 오류가 발생하면 다음과 같은 사항을 체크해보시기 바랍니다.

  • 파일 퍼미션(Permission)이 올바른지 체크
  • 수동으로 플러그인 설치
  • 서버 로그를 확인하여 문제의 원인 파악
  • 플러그인이 API 키나 기능을 요구하는 경우 해당 키나 기능이 올바르게 활성화되어 작동하는지 체크

플러그인 설치 파일이 있다면 수동으로 설치하는 것이 가장 간단할 것 같습니다.

워드프레스 플러그인 수동 설치하기

워드프레스 알림판에서 플러그인 업로드하여 설치하기

수동으로 플러그인을 설치하려면 먼저 플러그인 설치 파일을 zip 압축 파일 형식으로 가지고 있어야 합니다. 워드프레스 관리자 페이지에서 플러그인 > 새로 추가를 클릭하고 상단의 플러그인 추가 옆에 있는 플러그인 업로드 버튼을 클릭합니다.

그러면 파일을 업로드할 수 있는 화면이 표시됩니다.

플러그인 파일을 마우스로 끌어다가 놓거나 찾아보기...를 클릭하여 파일을 지정하여 설치할 수 있습니다.

FTP를 통해 플러그인 파일 업로드하여 설치하기

파일 퍼미션(권한) 오류가 있어 관리자 페이지에서 플러그인을 설치할 수 없는 경우 FTP를 통해 플러그인 파일을 업로드할 수 있습니다. 먼저 반디집과 같은 압축 해제 프로그램을 사용하여 압축 파일의 압축을 해제합니다. 그런 다음 FTP에 접속하여 /wp-content/plugins 폴더 아래로 플러그인 폴더를 업로드하도록 합니다.

FTP 사용 방법은 다음 글을 참고해보세요.

 

[워드프레스] FTP 사용하기 - 워드프레스 기본

워드프레스 작업에서도 다른 웹사이트 작업과 마찬가지로 FTP 사용이 필요한 경우가 많습니다. FTP는 File Transfer Protocol의 약어로 파일 전송 규약을 의미합니다. FTP를 통해 파일을 웹호스팅 서버로

www.thewordcracker.com

블루호스트나 사이트그라운드 호스팅을 이용하는 경우 File Manager (파일 관리자) 툴을 사용하여 압축 파일을 업로드한 후 압축을 해제하는 것도 가능합니다.

 

블루호스트에서 파일 관리자 (File Manager) 사용하기

홈페이지를 제작하거나 관리할 때 보통 FTP/sFTP를 통해 웹호스팅 서버에 파일을 업로드하거나 다운로드합니다. 해외 호스팅 중 하나인 블루호스트 (Bluehost)에서는 cPanel에서 파일 관리자 (File Manage

avada.tistory.com

마치며

이상으로 워드프레스에서 'Something went wrong with the plugin API' 오류가 발생하는 경우 대처 방법에 대해 살펴보았습니다.

유료 테마에 포함된 플러그인을 설치하는 과정에서 이 문제가 발생하면 테마 판매자에게 연락하여 플러인 설치 파일을 요청할 수 있을 것입니다.

참고

 

워드프레스 테마 수동 업데이트

워드프레스 테마는 보통 관리자 페이지에서 자동으로 업데이트가 가능합니다. 하지만 일부 유료 테마는 자동 업데이트 기능이 제공되지 않을 수 있습니다. 또한, 유료 테마의 경우 보통 인증을

avada.tistory.com

 

  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

">